В конце прошлой недели в магазине Google Play была замечена новая версия фирменного номеронабирателя Google. Ключевым отличием от предыдущих стал возросший список совместимых моделей, в который ранее входили лишь аппараты линеек Nexus, Android One и GPE.

Ошибка установки "Телефона" Google

Как оказалось, все это было не более, чем простой ошибкой. Исправили ее в течение пары-тройки часов и список совместимости вернулся к первоначальному виду. Для того, чтобы исключить возможность установки даже из APK, разработчики в обновленной версии добавили несколько строчек кода. Теперь приложение требует наличие библиотеки, которая есть только на устройствах упомянутых линеек. Установка на все прочие оказалась невозможна.

Конечно, энтузиасты, которые смогут «выдрать» нужную библиотеку из прошивок для Nexus всегда найдутся, как и те, кто ее установит на свое устройство. Вот только вряд ли подобные действия, к тому же лишающие смартфон гарантии, стоят простого приложения-«звонилки».

[via AndroidPolice]